lunes, 16 de septiembre de 2013

Cuando usaba Internet Explorer...

Hace muchos años, Microsoft fue acusada y sentenciada por el tribunal anticompetencia por 'colocar' Internet Explorer en sus Windows por sus santos Windows sin posibilidad de desinstalarlo.

Corporativamente eso daba igual... Todos los programas y aplicaciones que funcionaban por web pensaban fundamentalmente en IE y eran lo máximo posible de compatibles.

Luego el tiempo pasó y a IE no lo quiere nadie... Incluso los de Mozilla se recochinean mandándoles una tarta cada vez que sacan una versión nueva...

Nadie? Nadie no... Un grupo de irreductibles trabajadores corporativos sigue usándolo... Porque es sólo en entornos corporativos donde navegadores como Firefox o Chrome no acaban de funcionar bien con páginas web de aplicaciones con cerca de un lustro de antigüedad... Hasta ahora...

Y digo hasta ahora porque IE10 tampoco es totalmente compatible y tienes que forzar la retrocompatibilidad para que las cosas funcionen en entornos con aplicaciones un poco anticuadas...

Si además lo unes a Windows 8, el drama está servido:
-Es que con IE10 no se ve bien la página...
-Vale, forzaremos un meta que si es IE10 emule el IE9.
-Pero luego cuando lo veo en mi tablet con Windows 8 no se ve a pantalla completa...
-Es que hay que diferenciar entre el modo metro y el de escritorio y Microsoft no ofrece ningún método inequívoco de hacerlo...
-Entonces?
-Tienes que decidir si lo vemos en modo metro o desktop, pero sólo lo podrás ver de un modo de forma automática... O tener dos accesos diferentes...
-Dos accesos! Herejía! A la hoguera!

Ya no entro en lo 'ergonómico' e 'intuitivo' que es el modo metro de Windows 8 (supongo que como todo es falta de costumbre pero reitero que otros sistemas son mucho más intuitivos), pero de nuevo la carrera armamentística de los fabricantes de sistemas operativos de pcs no tienen en cuenta las necesidades de compatibilidad de aplicaciones que no son fáciles de migrar...

-Tu aplicación no va con IE10
-Es que tu versión sólo es compatible hasta IE9.
-Y qué hago?
-Migra a una versión posterior...
-Porque no me va bien el navegador? Simplemente por un tema técnico que podría solucionarse si hubieras sido previsor y hubieras incorporado un meta de emulación en tus páginas?
-Es que si no no migrarías... Y ése es mi negocio...
-Claro...

Por suerte, Chrome cuenta en su arsenal con IEtab, que lo transforma en un IE6 más compatible que el propio IE10 (cosa curiosa) y que resuelve, momentáneamente, la papeleta. En mi caso, por poner un ejemplo, no he podido hacer funcionar el cliente de vpn de fortinet con IE y sí con el IEtab de Chrome... Y no me considero un usuario inexperto...

En fin, supongo que los hay que se dan cuenta de lo que quiere el usuario y los que no... Y el tiempo y las versiones ponen a cada uno en su sitio, aunque haya que migrar.

Seguiremos informando.

No hay comentarios:

Publicar un comentario